洪永时交换机链路聚合-BLotus

洪永时交换机链路聚合-BLotus

洪永时1 系统描述
链路聚合是将多条链路聚合在一起形成一个汇聚组,以实现负荷在各成员链路中的分担,同时也提供了更高的连接可靠性。Cisco 的链路聚合有几种方式:手工、LACP(包括active 和passive 两种)、PAGP(Port-aggregation Protocol),其中PAGP是Cisco的私有协议,H3C平台交换机链路聚合有2种方式:Static(默认)、Dynamic(LACP)。
经测试,H3C与Cisco链路聚合可以对接成功的有以下两种组合:
H3CCisco测试结果Static模式(缺省)On模OKDynamic模Active模OK
2 测试网络拓扑

3 链路聚合方法和步骤
H3C 5500 、 H3C5120 配置
interface Bridge-Aggregation 1
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
//配置此时聚合方式为动态,对应Cisco的Active模式
//不配置则聚合方式缺省为静态,对应Cisco的On模式
interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1
//链路聚合成员接口配置
interface GigabitEthernet1/0/2
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1
//链路聚合成员接口配置
Cisco3750设备上配置如下:
interface Port-channel 1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all
switchport mode trunk
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all
switchport mode trunk
channel-group 1 mode active
//配置链路聚合方式为Active,对应我司动态聚合
//channel-group 1 mode on
//若配置链路聚合方式为On,则对应我司静态聚合
interfaceGigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all
switchport mode trunk
channel-group 1 mode active
//配置链路聚合方式为Active,对应我司动态聚合
//channel-group 1 mode on
//若配置链路聚合方式为On,则对应我司静态聚合
4.网络负载均衡方式:
一:基于源MAC(默认模式)适合用户同时访问多台服务器,如上Internet网
二:基于目标MAC适合多用户访问一台服务器,如公司内网
port-channel load-bance 负载均衡模式
负载均衡模式:
dst-ip:在网络三层交换条件下,基于目标ip
src-ip:在网络三层交换条件下,基于源ip
src-mac:在网络二层交换条件下,基于源MAC
dst-mac:在网络二层交换条件下,基于目的MAC
EtherChannel可以在一个通道中的多台链路上分担流量。默认的方法与负载分担的方法会因Cisco交换机系列的不同而有所不同。2960,3560,3750默认为src-mac,而4550和6500系列默认为src-dst-ip,这是三层交换机的推荐选项负载分担会在全局应用与交换机上的所有EtherChannel。管理员如需配置EtherChannel负载分担,可以使用命令port-channel load-balance来实现这项技术。负载分担的变量:src-mac:源MAC地址dst-mac:目的MAC地址src-dst-mac:源和目的MAC地址src-ip:源IP地址dst-ip:目的IP地址src-dst-ip:源和目的IP(默认)src-port:源TCP/UDP(用户数据包协议)端口dst-port:目的TCP/UDP端口src-dst-port:源和目的TCP/UDP端口上面的各类模式其实都可以顾名思义。比如,源MAC地址转发是指当数据包被发送给EtherChannel时,设备会根据入站数据包的源MAC地址来判断应该将数据包从通道的哪个端口转发出去。于是,来自不同主机的数据包就会从通道的不同端口中转发出去,而来自同一台主机的数据包也会从通道中的同一个端口中转发出去,这就实现了负载分担(而交换机学到的MAC地址并不会变化)而目的MAC地址转发是指当数据包被发送给EtherChannel时,设备会根据数据帧的目的MAC地址来判断应该将数据包从通道的哪个端口转发出去。于是去往统一目的地的数据包就会从通道的同一个端口中转发出去,而去往不同主机的数据包则会从通道的不同端口中转发出去。


5.注意:
链路聚合的两端设备需要同一个channel号码,即cisco上的channel 2
对用h3c的也要是channel 2
6.配置
CISCO3750:


H3C: